注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

我的小窝

slackware爱好者

 
 
 

日志

 
 

安装LINUX下摄像头失败经历!!  

2006-12-01 16:09:58|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
一台老机器 ,一个摄像头,本来想利用,想在LINUX系统下装上摄像头试试,没有想到痛苦的经历开始了!!
首先机器上的LINUX版本是SLACKWARE10.2,内核用的是2.4.31,USB摄像头的驱动是网上下的叫spca5xx的驱动!!
按照下来的驱动中的README的说明,应该来说,我的内核在支持范围之内的啊!!结果编译驱动第一步就失败了,N多错误!!
?
那我想啊,干脆升级到2.6.18好了,正好前几天刚下了新的内核,所以呢升级到了新的内核,果然升级内核后成功编译了驱动程序,
不过启动摄像头程序,spcaview后发现找不到V4L的设备提示后,害我又回去编译了一遍内核。(不知道是什么问题,我编译进内核是不行的,一定以模块的形式挂载,不知道是不是我机器问题)
?
由于升级到了2.6.18版本,原来的驱动也要换成gscap的版本驱动,挂载gscap和videodev,用lsmod查看一下,是否挂载成功!!
?
最后应该是让人兴奋的时刻了啊,启动spcaview -d /dev/video0,结果出来个黑框~安装LINUX下摄像头失败经历!! - 小牛 - 我的小窝~~大受打击~~
~~无比痛心中………………
?
PS:我的摄像头应该是微星的305B的芯片
  评论这张
 
阅读(102)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017